Now that the McAfee SECURE certification has transitioned to TrustedSite Certification, we've ended support for the McAfee SECURE plugin for Wordpress. It will continue to function for the foreseeable future but will not receive future updates, including new product features, bug fixes, security patches, and official support for versions of Wordpress after 5.7.2.

We recommend updating to the TrustedSite plugin. To update:

Install the TrustedSite plugin

  1. Download the TrustedSite plugin for Wordpress.

  2. Upload trustedsite to the /wp-content/plugins/ directory.

  3. Activate the plugin through the ‘Plugins’ menu in WordPress.

Remove the McAfee SECURE plugin

  1. Once the TrustedSite plugin has been installed, you can remove the McAfee SECURE plugin.

  2. From your Wordpress Admin dashboard, select Plugins → Installed plugins.

  3. Locate the McAfee SECURE plugin on the list and select Deactivate.

  4. After the page refreshes, select the Delete link below the plugin title.

  5. Confirm you’d like to delete the files by selecting Yes, Delete these files.

Your account will stay the same and the existing trustmarks will continue to work as before. If you have any questions, we’re here to help.

Did this answer your question?